Build:
  1. 0
2021-11-25 10:11.33: New job: Build using linux-arm64 in
                                [https://github.com/mirage/mirage-skeleton.git#refs/heads/mirage-dev (23ffdff3e7f022f7c9a7f94f6cf5bee8600fc33d)]

OBuilder spec:

((from ocaml/opam:debian-10-ocaml-4.13)
 (user (uid 1000) (gid 1000))
 (workdir /home/opam)
 (run (shell "sudo chown opam:opam /home/opam"))
 (run (shell "sudo ln -f /usr/bin/opam-2.1 /usr/bin/opam && opam update"))
 (run (network host)
      (shell "opam repo add opam https://github.com/ocaml/opam-repository.git#03fce0486d9ff1899862edf5b75cbc44adc38393"))
 (run (network host)
      (shell "opam repo add mirage-dev https://github.com/mirage/mirage-dev.git#9961f11531969591073dc4adec35b8143286fa96"))
 (run (cache (download-cache (target /home/opam/.opam/download-cache)))
      (network host)
      (shell "opam install -y mirage"))
 (copy (src .) (dst /src/))
 (env MODE hvt)
 (workdir /src/)
 (run (shell "opam exec -- make configure"))
 (env OVERLAY https://github.com/mirage/opam-overlays.git#f033f8b770097e768cc974cc407e0cd6d7889d63)
 (run (network host)
      (shell "opam exec -- make lock"))
 (run (cache (download-cache (target /home/opam/.opam/download-cache)))
      (network host)
      (shell "opam exec -- make depends"))
 (run (cache (download-cache (target /home/opam/.opam/download-cache)))
      (network host)
      (shell "opam exec -- make pull"))
 (env DUNE_CACHE enabled)
 (env DUNE_CACHE_TRANSPORT direct)
 (run (cache (dune-build-cache (target /home/opam/.cache/dune)))
      (shell "opam exec -- make build"))
)

2021-11-25 10:11.33: Using cache hint "mirage-ci-skeleton-debian-10-ocaml-4.13"
2021-11-25 10:11.33: Waiting for resource in pool OCluster
2021-11-25 10:11.33: Waiting for worker...
2021-11-25 10:11.39: Got resource from pool OCluster
Building on arm64-jade-1.ocamllabs.io
All commits already cached
HEAD is now at 23ffdff Merge pull request #317 from dinosaure/upgrade-git

(from ocaml/opam:debian-10-ocaml-4.13)
Unable to find image 'ocaml/opam:debian-10-ocaml-4.13' locally
debian-10-ocaml-4.13: Pulling from ocaml/opam
2ff6d7a9e7d7: Pulling fs layer
9bfc1cf9e325: Pulling fs layer
c35e13cdae6f: Pulling fs layer
2ff6d7a9e7d7: Verifying Checksum
2ff6d7a9e7d7: Download complete
2ff6d7a9e7d7: Pull complete
c35e13cdae6f: Verifying Checksum
c35e13cdae6f: Download complete
9bfc1cf9e325: Verifying Checksum
9bfc1cf9e325: Download complete
9bfc1cf9e325: Pull complete
c35e13cdae6f: Pull complete
Digest: sha256:0b6b68bbf8ae80f9f23b0cc0a8393f8f5b8fb13632e39f94c9c6573eca227e79
Status: Downloaded newer image for ocaml/opam:debian-10-ocaml-4.13
2021-11-25 10:11.40 ---> using "cbba9511e46ef57631453d5b88aeed1ed6de6fa87b6f0dcb3da9328657d73fa4" from cache

/: (user (uid 1000) (gid 1000))

/: (workdir /home/opam)

/home/opam: (run (shell "sudo chown opam:opam /home/opam"))
2021-11-25 10:11.40 ---> using "0afede13af6ea6d75cbfcfb80353059bc4fd4eea40a723ef627f0c4946f2e079" from cache

/home/opam: (run (shell "sudo ln -f /usr/bin/opam-2.1 /usr/bin/opam && opam update"))
This development version of opam requires an update to the layout of /home/opam/.opam from version 2.0 to version 2.1, which can't be reverted.
You may want to back it up before going further.

Continue? [Y/n] y
Format upgrade done.

<><> Updating package repositories ><><><><><><><><><><><><><><><><><><><><><><>
[default] synchronised from file:///home/opam/opam-repository
2021-11-25 10:11.40 ---> using "88933084999984163bc104ca2978b0ba2b9c83ff33e4e30c3b6dae7cb5cde9bc" from cache

/home/opam: (run (network host)
                 (shell "opam repo add opam https://github.com/ocaml/opam-repository.git#03fce0486d9ff1899862edf5b75cbc44adc38393"))
[opam] Initialised
[NOTE] Repository opam has been added to the selections of switch 4.13 only.
       Run `opam repository add opam --all-switches|--set-default' to use it in all existing switches, or in newly created switches, respectively.

2021-11-25 10:12.06 ---> saved as "4283964b7c0013a4a28ac69e8a14960d309b96f778a72a13bcf65b9849940db3"

/home/opam: (run (network host)
                 (shell "opam repo add mirage-dev https://github.com/mirage/mirage-dev.git#9961f11531969591073dc4adec35b8143286fa96"))
[mirage-dev] Initialised
[NOTE] Repository mirage-dev has been added to the selections of switch 4.13 only.
       Run `opam repository add mirage-dev --all-switches|--set-default' to use it in all existing switches, or in newly created switches, respectively.

2021-11-25 10:12.09 ---> saved as "313e0d346362c452f105e6d702a3f56ab3968b25ab956a731b9342a6fb2399c0"

/home/opam: (run (cache (download-cache (target /home/opam/.opam/download-cache)))
                 (network host)
                 (shell "opam install -y mirage"))
The following actions will be performed:
  - install seq                base    [required by lwt]
  - install ocamlbuild         0.14.0  [required by astring, bos]
  - install conf-pkg-config    2       [required by bigstringaf]
  - install ocamlfind          1.9.1   [required by astring, bos]
  - install cmdliner           1.0.4   [required by functoria, opam-monorepo]
  - install dune               2.9.1   [required by mirage]
  - install topkg              1.0.4   [required by astring, bos]
  - install num                1.4     [required by sexplib]
  - install base-bytes         base    [required by stringext]
  - install stdlib-shims       0.3.0   [required by ipaddr]
  - install sexplib0           v0.14.0 [required by base, sexplib]
  - install result             1.5     [required by lwt, angstrom]
  - install re                 1.10.3  [required by opam-format]
  - install opam-file-format   2.1.3   [required by opam-monorepo]
  - install ocaml-version      3.4.0   [required by opam-monorepo]
  - install ocaml-syntax-shims 1.0.0   [required by lwt, angstrom]
  - install mmap               1.1.0   [required by lwt]
  - install macaddr            5.2.0   [required by ipaddr]
  - install dune-build-info    2.9.1   [required by opam-monorepo]
  - install domain-name        0.3.1   [required by ipaddr]
  - install csexp              1.5.1   [required by dune-configurator]
  - install cppo               1.6.8   [required by lwt]
  - install bigarray-compat    1.0.0   [required by bigstringaf]
  - install 0install-solver    2.17    [required by opam-0install]
  - install rresult            0.7.0   [required by bos, functoria]
  - install fmt                0.9.0   [required by mirage-runtime, bos, functoria, opam-monorepo]
  - install astring            0.8.5   [required by mirage]
  - install stringext          1.6.0   [required by uri]
  - install ocamlgraph         2.0.0   [required by functoria]
  - install ptime              0.8.5
  - install ipaddr             5.2.0   [required by mirage]
  - install dune-configurator  2.9.1   [required by base]
  - install ocplib-endian      1.2     [required by lwt]
  - install bigstringaf        0.8.0   [required by angstrom]
  - install fpath              0.7.3   [required by bos, functoria]
  - install opam-core          2.1.1   [required by opam-format]
  - install base               v0.14.2 [required by opam-monorepo]
  - install lwt                5.4.2   [required by mirage-runtime]
  - install angstrom           0.15.0  [required by uri]
  - install opam-format        2.1.1   [required by opam-monorepo]
  - install parsexp            v0.14.2 [required by sexplib]
  - install logs               0.7.0   [required by mirage]
  - install uri                4.2.0   [required by opam-monorepo]
  - install opam-repository    2.1.1   [required by opam-state]
  - install sexplib            v0.14.0 [required by opam-monorepo]
  - install bos                0.2.1   [required by mirage]
  - install opam-state         2.1.1   [required by opam-monorepo]
  - install functoria-runtime  4.0.0   [required by mirage-runtime]
  - install functoria          4.0.0   [required by mirage]
  - install opam-0install      dev     [required by opam-monorepo]
  - install mirage-runtime     4.0.0   [required by mirage]
  - install opam-monorepo      dev     [required by mirage]
  - install mirage             4.0.0
===== 53 to install =====

The following system packages will first need to be installed:
    pkg-config

<><> Handling external dependencies <><><><><><><><><><><><><><><><><><><><><><>
Let opam run your package manager to install the required system packages?
(answer 'n' for other options) [Y/n] y
+ /usr/bin/sudo "apt-get" "install" "-qq" "-yy" "pkg-config"
- debconf: delaying package configuration, since apt-utils is not installed
- Selecting previously unselected package libglib2.0-0:arm64.
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 17364 files and directories currently installed.)
- Preparing to unpack .../0-libglib2.0-0_2.58.3-2+deb10u3_arm64.deb ...
- Unpacking libglib2.0-0:arm64 (2.58.3-2+deb10u3) ...
- Selecting previously unselected package libglib2.0-data.
- Preparing to unpack .../1-libglib2.0-data_2.58.3-2+deb10u3_all.deb ...
- Unpacking libglib2.0-data (2.58.3-2+deb10u3) ...
- Selecting previously unselected package libicu63:arm64.
- Preparing to unpack .../2-libicu63_63.1-6+deb10u1_arm64.deb ...
- Unpacking libicu63:arm64 (63.1-6+deb10u1) ...
- Selecting previously unselected package libxml2:arm64.
- Preparing to unpack .../3-libxml2_2.9.4+dfsg1-7+deb10u2_arm64.deb ...
- Unpacking libxml2:arm64 (2.9.4+dfsg1-7+deb10u2) ...
- Selecting previously unselected package pkg-config.
- Preparing to unpack .../4-pkg-config_0.29-6_arm64.deb ...
- Unpacking pkg-config (0.29-6) ...
- Selecting previously unselected package shared-mime-info.
- Preparing to unpack .../5-shared-mime-info_1.10-1_arm64.deb ...
- Unpacking shared-mime-info (1.10-1) ...
- Selecting previously unselected package xdg-user-dirs.
- Preparing to unpack .../6-xdg-user-dirs_0.17-2_arm64.deb ...
- Unpacking xdg-user-dirs (0.17-2) ...
- Setting up xdg-user-dirs (0.17-2) ...
- Setting up libglib2.0-0:arm64 (2.58.3-2+deb10u3) ...
- No schema files found: doing nothing.
- Setting up libicu63:arm64 (63.1-6+deb10u1) ...
- Setting up libglib2.0-data (2.58.3-2+deb10u3) ...
- Setting up pkg-config (0.29-6) ...
- Setting up libxml2:arm64 (2.9.4+dfsg1-7+deb10u2) ...
- Setting up shared-mime-info (1.10-1) ...
- Processing triggers for libc-bin (2.28-10) ...

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved astring.0.8.5  (cached)
-> retrieved angstrom.0.15.0  (cached)
-> retrieved 0install-solver.2.17  (cached)
-> retrieved base.v0.14.2  (cached)
-> retrieved bigarray-compat.1.0.0  (cached)
-> retrieved bigstringaf.0.8.0  (cached)
-> retrieved bos.0.2.1  (cached)
-> retrieved cmdliner.1.0.4  (cached)
-> retrieved cppo.1.6.8  (cached)
-> retrieved csexp.1.5.1  (cached)
-> retrieved domain-name.0.3.1  (cached)
-> retrieved dune.2.9.1  (cached)
-> installed conf-pkg-config.2
-> retrieved dune-build-info.2.9.1  (cached)
-> retrieved dune-configurator.2.9.1  (cached)
-> retrieved fmt.0.9.0  (cached)
-> retrieved fpath.0.7.3  (cached)
-> installed cmdliner.1.0.4
-> retrieved ipaddr.5.2.0  (cached)
-> retrieved logs.0.7.0  (cached)
-> retrieved lwt.5.4.2  (cached)
-> retrieved macaddr.5.2.0  (cached)
-> retrieved functoria-runtime.4.0.0  (git+https://github.com/mirage/mirage.git#8829635b063526c1fe70d66cb4d9074cd4a2ef99)
-> retrieved functoria.4.0.0  (git+https://github.com/mirage/mirage.git#8829635b063526c1fe70d66cb4d9074cd4a2ef99)
-> retrieved mmap.1.1.0  (cached)
-> retrieved num.1.4  (cached)
-> retrieved ocaml-syntax-shims.1.0.0  (cached)
-> retrieved ocaml-version.3.4.0  (cached)
-> retrieved ocamlbuild.0.14.0  (cached)
-> retrieved ocamlfind.1.9.1  (cached)
-> retrieved mirage.4.0.0  (git+https://github.com/mirage/mirage.git#8829635b063526c1fe70d66cb4d9074cd4a2ef99)
-> retrieved ocamlgraph.2.0.0  (cached)
-> retrieved ocplib-endian.1.2  (cached)
-> retrieved mirage-runtime.4.0.0  (git+https://github.com/mirage/mirage.git#8829635b063526c1fe70d66cb4d9074cd4a2ef99)
-> retrieved opam-file-format.2.1.3  (cached)
-> retrieved opam-core.2.1.1  (cached)
-> retrieved opam-format.2.1.1  (cached)
-> retrieved opam-repository.2.1.1  (cached)
-> retrieved opam-monorepo.dev  (git+https://github.com/samoht/opam-monorepo.git#9d030f307f9054039e9ccd666f997d9bbdd69497)
-> retrieved opam-state.2.1.1  (cached)
-> retrieved ptime.0.8.5  (cached)
-> retrieved parsexp.v0.14.2  (https://github.com/TheLortex/parsexp/archive/refs/tags/v0.14.2.tar.gz)
-> retrieved re.1.10.3  (cached)
-> retrieved result.1.5  (cached)
-> installed seq.base
-> retrieved rresult.0.7.0  (cached)
-> retrieved opam-0install.dev  (git+https://github.com/ocaml-opam/opam-0install-solver.git#4eede964fabba756e4c3c825f15da3bb499a9356)
-> retrieved sexplib.v0.14.0  (cached)
-> retrieved sexplib0.v0.14.0  (cached)
-> retrieved stdlib-shims.0.3.0  (cached)
-> retrieved stringext.1.6.0  (cached)
-> retrieved topkg.1.0.4  (cached)
-> retrieved uri.4.2.0  (cached)
-> installed ocamlfind.1.9.1
-> installed base-bytes.base
-> installed dune.2.9.1
-> installed ocamlbuild.0.14.0
-> installed num.1.4
-> installed 0install-solver.2.17
-> installed bigarray-compat.1.0.0
-> installed cppo.1.6.8
-> installed csexp.1.5.1
-> installed domain-name.0.3.1
-> installed dune-build-info.2.9.1
-> installed macaddr.5.2.0
-> installed mmap.1.1.0
-> installed ocaml-version.3.4.0
-> installed result.1.5
-> installed stdlib-shims.0.3.0
-> installed stringext.1.6.0
-> installed ocaml-syntax-shims.1.0.0
-> installed opam-file-format.2.1.3
-> installed re.1.10.3
-> installed sexplib0.v0.14.0
-> installed bigstringaf.0.8.0
-> installed ocplib-endian.1.2
-> installed ipaddr.5.2.0
-> installed angstrom.0.15.0
-> installed dune-configurator.2.9.1
-> installed topkg.1.0.4
-> installed uri.4.2.0
-> installed rresult.0.7.0
-> installed ocamlgraph.2.0.0
-> installed fmt.0.9.0
-> installed astring.0.8.5
-> installed ptime.0.8.5
-> installed fpath.0.7.3
-> installed lwt.5.4.2
-> installed logs.0.7.0
-> installed opam-core.2.1.1
-> installed bos.0.2.1
-> installed base.v0.14.2
-> installed functoria-runtime.4.0.0
-> installed mirage-runtime.4.0.0
-> installed functoria.4.0.0
-> installed parsexp.v0.14.2
-> installed sexplib.v0.14.0
-> installed opam-format.2.1.1
-> installed opam-repository.2.1.1
-> installed opam-state.2.1.1
-> installed opam-0install.dev
-> installed opam-monorepo.dev
-> installed mirage.4.0.0
Done.
# Run eval $(opam env) to update the current shell environment
2021-11-25 10:14.05 ---> saved as "f6dcacd9d97195c7c387838ccd2ec15ce9d42f0bb048a57e6e78ccd33c3a7c3c"

/home/opam: (copy (src .) (dst /src/))
2021-11-25 10:14.06 ---> saved as "3474baf7e72f69d9c4e0c856c4e2fe3e9aae813633da3acb39a391512a1521a7"

/home/opam: (env MODE hvt)

/home/opam: (workdir /src/)

/src/: (run (shell "opam exec -- make configure"))
mirage configure -f tutorial/noop/config.ml -t hvt 
mirage configure -f tutorial/noop-functor/config.ml -t hvt 
mirage configure -f tutorial/hello/config.ml -t hvt 
mirage configure -f tutorial/hello-key/config.ml -t hvt 
mirage configure -f tutorial/lwt/echo_server/config.ml -t hvt 
mirage configure -f tutorial/lwt/heads1/config.ml -t hvt 
mirage configure -f tutorial/lwt/heads2/config.ml -t hvt 
mirage configure -f tutorial/lwt/timeout1/config.ml -t hvt 
mirage configure -f tutorial/lwt/timeout2/config.ml -t hvt 
mirage configure -f tutorial/app_info/config.ml -t hvt 
mirage configure -f device-usage/clock/config.ml -t hvt 
mirage configure -f device-usage/conduit_server/config.ml -t hvt 
mirage configure -f device-usage/console/config.ml -t hvt 
mirage configure -f device-usage/http-fetch/config.ml -t hvt 
mirage configure -f device-usage/kv_ro/config.ml -t hvt 
mirage configure -f device-usage/network/config.ml -t hvt 
mirage configure -f device-usage/ping6/config.ml -t hvt 
mirage configure -f device-usage/prng/config.ml -t hvt 
mirage configure -f applications/dhcp/config.ml -t hvt 
mirage configure -f applications/git/config.ml -t hvt 
mirage configure -f applications/crypto/config.ml -t hvt 
mirage configure -f applications/static_website_tls/config.ml -t hvt 
mirage configure -f device-usage/block/config.ml -t hvt 
2021-11-25 10:14.20 ---> saved as "49961af8622660f68d37e05f52c343a0352451eef2df4b237cbfddc5513a3c0e"

/src/: (env OVERLAY https://github.com/mirage/opam-overlays.git#f033f8b770097e768cc974cc407e0cd6d7889d63)

/src/: (run (network host)
            (shell "opam exec -- make lock"))
[dune-universe] Initialised
[NOTE] Repository dune-universe has been added to the selections of switch 4.13 only.
       Run `opam repository add dune-universe --all-switches|--set-default' to use it in all existing switches, or in newly created switches, respectively.

opam monorepo lock --build-only --ocaml-version 4.13.1 -l ./mirage.opam.locked
==> Using 23 locally scanned packages as the roots.
==> Found 174 opam dependencies for the root packages.
==> Querying opam database for their metadata and Dune compatibility.
==> Calculating exact pins for each of them.
==> Wrote lockfile with 123 entries to mirage.opam.locked. You can now run opam monorepo pull to fetch their sources.
Repositories removed from the selections of switch 4.13. Use '--all' to forget about them altogether.
2021-11-25 10:14.58 ---> saved as "cc64296db17e39c1c4cc24c02f786b195dc27ded6fb1c89085c40f91445bf13f"

/src/: (run (cache (download-cache (target /home/opam/.opam/download-cache)))
            (network host)
            (shell "opam exec -- make depends"))
opam install  tutorial/noop/mirage/*-switch.opam  tutorial/noop-functor/mirage/*-switch.opam  tutorial/hello/mirage/*-switch.opam  tutorial/hello-key/mirage/*-switch.opam  tutorial/lwt/echo_server/mirage/*-switch.opam  tutorial/lwt/heads1/mirage/*-switch.opam  tutorial/lwt/heads2/mirage/*-switch.opam  tutorial/lwt/timeout1/mirage/*-switch.opam  tutorial/lwt/timeout2/mirage/*-switch.opam  tutorial/lwt/echo_server/mirage/*-switch.opam  tutorial/app_info/mirage/*-switch.opam  device-usage/clock/mirage/*-switch.opam  device-usage/conduit_server/mirage/*-switch.opam  device-usage/console/mirage/*-switch.opam  device-usage/http-fetch/mirage/*-switch.opam  device-usage/kv_ro/mirage/*-switch.opam  device-usage/network/mirage/*-switch.opam  device-usage/ping6/mirage/*-switch.opam  device-usage/prng/mirage/*-switch.opam  applications/dhcp/mirage/*-switch.opam  applications/git/mirage/*-switch.opam  applications/crypto/mirage/*-switch.opam  applications/static_website_tls/mirage/*-switch.opam  device-usage/block/mirage/*-switch.opam --deps-only --yes
The following actions will be performed:
  - install   conf-libseccomp    1
  - install   ocaml-src          4.13.1
  - install   solo5              0.7.0
  - install   ocaml-freestanding 0.7.0
  - recompile bigstringaf        0.8.0
  - recompile angstrom           0.15.0
  - recompile uri                4.2.0
  - recompile opam-monorepo      dev
  - recompile mirage             4.0.0
===== 4 to install | 5 to recompile =====

The following system packages will first need to be installed:
    libseccomp-dev

<><> Handling external dependencies <><><><><><><><><><><><><><><><><><><><><><>
Let opam run your package manager to install the required system packages?
(answer 'n' for other options) [Y/n] y
+ /usr/bin/sudo "apt-get" "install" "-qq" "-yy" "libseccomp-dev"
- debconf: delaying package configuration, since apt-utils is not installed
- Selecting previously unselected package libseccomp-dev:arm64.
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 17755 files and directories currently installed.)
- Preparing to unpack .../libseccomp-dev_2.3.3-4_arm64.deb ...
- Unpacking libseccomp-dev:arm64 (2.3.3-4) ...
- Setting up libseccomp-dev:arm64 (2.3.3-4) ...

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved angstrom.0.15.0  (cached)
-> retrieved bigstringaf.0.8.0  (cached)
-> installed conf-libseccomp.1
-> retrieved ocaml-src.4.13.1  (cached)
-> retrieved ocaml-freestanding.0.7.0  (git+https://github.com/TheLortex/ocaml-freestanding.git#9ba5d880d4d6a4b01a552082a51c7761c03e813c)
-> retrieved mirage.4.0.0  (no changes)
-> retrieved uri.4.2.0  (cached)
-> retrieved opam-monorepo.dev  (no changes)
-> retrieved solo5.0.7.0  (git+https://github.com/TheLortex/solo5.git#77db27433ccd5b1ec13735e8ef1c92e141969a5c)
-> installed ocaml-src.4.13.1
-> removed   mirage.4.0.0
-> removed   opam-monorepo.dev
-> removed   uri.4.2.0
-> removed   angstrom.0.15.0
-> removed   bigstringaf.0.8.0
-> installed solo5.0.7.0
-> installed ocaml-freestanding.0.7.0
-> installed bigstringaf.0.8.0
-> installed angstrom.0.15.0
-> installed uri.4.2.0
-> installed opam-monorepo.dev
-> installed mirage.4.0.0
Done.
opam monorepo depext -y -l ./mirage.opam.locked
==> Pulling lockfile mirage.opam.locked
+ /usr/bin/sudo "apt-get" "install" "-qq" "-yy" "libgmp-dev" "m4"
- debconf: delaying package configuration, since apt-utils is not installed
- Selecting previously unselected package libgmpxx4ldbl:arm64.
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 17788 files and directories currently installed.)
- Preparing to unpack .../libgmpxx4ldbl_2%3a6.1.2+dfsg-4_arm64.deb ...
- Unpacking libgmpxx4ldbl:arm64 (2:6.1.2+dfsg-4) ...
- Selecting previously unselected package libgmp-dev:arm64.
- Preparing to unpack .../libgmp-dev_2%3a6.1.2+dfsg-4_arm64.deb ...
- Unpacking libgmp-dev:arm64 (2:6.1.2+dfsg-4) ...
- Selecting previously unselected package libsigsegv2:arm64.
- Preparing to unpack .../libsigsegv2_2.12-2_arm64.deb ...
- Unpacking libsigsegv2:arm64 (2.12-2) ...
- Selecting previously unselected package m4.
- Preparing to unpack .../archives/m4_1.4.18-2_arm64.deb ...
- Unpacking m4 (1.4.18-2) ...
- Setting up libgmpxx4ldbl:arm64 (2:6.1.2+dfsg-4) ...
- Setting up libsigsegv2:arm64 (2.12-2) ...
- Setting up libgmp-dev:arm64 (2:6.1.2+dfsg-4) ...
- Setting up m4 (1.4.18-2) ...
- Processing triggers for libc-bin (2.28-10) ...
2021-11-25 10:16.50 ---> saved as "f92d4247eff43be4e79bf2f70d3fd74b57ce7b072df04feb1f3cb9605db7ed52"

/src/: (run (cache (download-cache (target /home/opam/.opam/download-cache)))
            (network host)
            (shell "opam exec -- make pull"))
opam monorepo pull
==> Pulling lockfile /src/mirage.opam.locked
Successfully pulled 121/121 repositories
2021-11-25 10:16.55 ---> saved as "5f25f458f8f2092a426b6c2d023082e62cc180f98b587043e6bcf9e2d60766e0"

/src/: (env DUNE_CACHE enabled)

/src/: (env DUNE_CACHE_TRANSPORT direct)

/src/: (run (cache (dune-build-cache (target /home/opam/.cache/dune)))
            (shell "opam exec -- make build"))
dune build
File "/src/_build/.dune/default/duniverse/lwt/src/unix/luv/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/lwt/src/unix/luv/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/lwt/src/unix/luv/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/lwt/src/unix/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/lwt/src/unix/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/lwt/src/unix/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/lwt/src/react/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/lwt/src/react/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/lwt/src/react/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/lwt/src/ppx/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/lwt/src/ppx/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/lwt/src/ppx/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/0install/src/windows/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/0install/src/windows/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/0install/src/windows/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/lwt/src/core/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/lwt/src/core/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/lwt/src/core/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/stdlib-shims/src/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/stdlib-shims/src/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/stdlib-shims/src/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/lwt/src/unix/luv/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/lwt/src/unix/luv/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/lwt/src/unix/luv/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/lwt/src/unix/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/lwt/src/unix/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/lwt/src/unix/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/lwt/src/react/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/lwt/src/react/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/lwt/src/react/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/0install/src/gui_gtk/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/0install/src/gui_gtk/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/0install/src/gui_gtk/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
ocamlfind: Package `lablgtk3' not found
(will skip building the GTK plugin)
File "/src/_build/.dune/default/duniverse/bigarray-compat/src/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/bigarray-compat/src/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/default/duniverse/bigarray-compat/src/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/lwt/src/ppx/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/lwt/src/ppx/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/lwt/src/ppx/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/stdlib-shims/src/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/stdlib-shims/src/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/stdlib-shims/src/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/lwt/src/core/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/lwt/src/core/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/lwt/src/core/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/bigarray-compat/src/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/bigarray-compat/src/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/bigarray-compat/src/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/0install/src/windows/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/0install/src/windows/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/0install/src/windows/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/0install/src/gui_gtk/dune.ml", line 28, characters 14-37:
28 |   Hashtbl.add Toploop.directive_table "require"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/0install/src/gui_gtk/dune.ml", line 30, characters 14-37:
30 |   Hashtbl.add Toploop.directive_table "use"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
File "/src/_build/.dune/mirage-hvt/duniverse/0install/src/gui_gtk/dune.ml", line 34, characters 14-37:
34 |   Hashtbl.add Toploop.directive_table "use_mod"
                   ^^^^^^^^^^^^^^^^^^^^^^^
Alert deprecated: Toploop.directive_table
ocamlfind: Package `lablgtk3' not found
(will skip building the GTK plugin)
File "duniverse/base/compiler-stdlib/gen/dune", line 1, characters 20-23:
1 | (executables (names gen)
                        ^^^
Error: File unavailable:
/home/opam/.opam/4.13/freestanding-sysroot/lib/ocaml/compiler-libs/ocamlbytecomp.cmxa
File "duniverse/base/compiler-stdlib/gen/dune", line 1, characters 20-23:
1 | (executables (names gen)
                        ^^^
Error: File unavailable:
/home/opam/.opam/4.13/freestanding-sysroot/lib/ocaml/compiler-libs/ocamlcommon.cmxa
File "duniverse/opam/src/client/dune", line 6, characters 57-63:
6 |   (libraries   opam-state opam-solver opam-repository re extlib cmdliner)
                                                             ^^^^^^
Error: Library "extlib" not found.
Hint: try:
  dune external-lib-deps --missing @@default
make: *** [Makefile:75: build] Error 1
"/bin/bash" "-c" "opam exec -- make build" failed with exit status 2
2021-11-25 10:17.13: Job failed: Failed: Build failed