Build:
  1. 0
2022-01-14 16:00.29: New job: Build using linux-x86_64 in
                                [https://github.com/mirage/mirage-skeleton.git#refs/heads/mirage-dev (5835262d437b37ef54aa994deae06c6ca3852b72)]

OBuilder spec:

((from ocaml/opam:debian-10-ocaml-4.13)
 (user (uid 1000) (gid 1000))
 (workdir /home/opam)
 (run (shell "sudo chown opam:opam /home/opam"))
 (run (shell "sudo ln -f /usr/bin/opam-2.1 /usr/bin/opam && opam update"))
 (run (network host)
      (shell "opam repo add opam https://github.com/ocaml/opam-repository.git#ccfbafd8f67a00c32611625339d88ffbdc816add"))
 (run (network host)
      (shell "opam repo add mirage-dev https://github.com/mirage/mirage-dev.git#b7486315070c8d96c5d1133df17b92277bb421d1"))
 (run (cache (download-cache (target /home/opam/.opam/download-cache)))
      (network host)
      (shell "opam install -y mirage"))
 (copy (src .) (dst /src/))
 (env MODE hvt)
 (workdir /src/)
 (run (shell "opam exec -- make configure"))
 (env OVERLAY https://github.com/mirage/opam-overlays.git#3efd7da5947ed628eaa77e2253aa03bd1ac3867c)
 (run (network host)
      (shell "opam exec -- make lock"))
 (run (cache (download-cache (target /home/opam/.opam/download-cache)))
      (network host)
      (shell "opam exec -- make depends"))
 (run (shell "opam monorepo list -l mirage.opam.locked"))
 (run (cache (download-cache (target /home/opam/.opam/download-cache)))
      (network host)
      (shell "opam exec -- make pull"))
 (env DUNE_CACHE enabled)
 (env DUNE_CACHE_TRANSPORT direct)
 (run (cache (dune-build-cache (target /home/opam/.cache/dune)))
      (shell "opam exec -- make build"))
)

2022-01-14 16:00.29: Using cache hint "mirage-ci-skeleton-debian-10-ocaml-4.13"
2022-01-14 16:00.29: Waiting for resource in pool OCluster
2022-01-14 16:15.33: Waiting for worker...
2022-01-14 16:39.33: Got resource from pool OCluster
Building on x86-bm-1.ocamllabs.io
All commits already cached
HEAD is now at 5835262 Merge pull request #327 from mirage/mirage-stack

(from ocaml/opam:debian-10-ocaml-4.13)
2022-01-14 16:39.33 ---> using "cbba9511e46ef57631453d5b88aeed1ed6de6fa87b6f0dcb3da9328657d73fa4" from cache

/: (user (uid 1000) (gid 1000))

/: (workdir /home/opam)

/home/opam: (run (shell "sudo chown opam:opam /home/opam"))
2022-01-14 16:39.33 ---> using "0afede13af6ea6d75cbfcfb80353059bc4fd4eea40a723ef627f0c4946f2e079" from cache

/home/opam: (run (shell "sudo ln -f /usr/bin/opam-2.1 /usr/bin/opam && opam update"))
This version of opam requires an update to the layout of /home/opam/.opam from version 2.0 to version 2.1, which can't be reverted.
You may want to back it up before going further.

Continue? [Y/n] y
Format upgrade done.

<><> Updating package repositories ><><><><><><><><><><><><><><><><><><><><><><>
[default] synchronised from file:///home/opam/opam-repository
2022-01-14 16:39.33 ---> using "88933084999984163bc104ca2978b0ba2b9c83ff33e4e30c3b6dae7cb5cde9bc" from cache

/home/opam: (run (network host)
                 (shell "opam repo add opam https://github.com/ocaml/opam-repository.git#ccfbafd8f67a00c32611625339d88ffbdc816add"))
[opam] Initialised
[NOTE] Repository opam has been added to the selections of switch 4.13 only.
       Run `opam repository add opam --all-switches|--set-default' to use it in all existing switches, or in newly created switches, respectively.

2022-01-14 16:39.33 ---> using "847573cc8e924c7f2545723302f48e4340fe3feb3462a518280daed8eb640dde" from cache

/home/opam: (run (network host)
                 (shell "opam repo add mirage-dev https://github.com/mirage/mirage-dev.git#b7486315070c8d96c5d1133df17b92277bb421d1"))
[mirage-dev] Initialised
[NOTE] Repository mirage-dev has been added to the selections of switch 4.13 only.
       Run `opam repository add mirage-dev --all-switches|--set-default' to use it in all existing switches, or in newly created switches, respectively.

2022-01-14 16:39.37 ---> saved as "5eb96690ce6aacde55d62818b52436a399c84205147a735023c8057027aa1a96"

/home/opam: (run (cache (download-cache (target /home/opam/.opam/download-cache)))
                 (network host)
                 (shell "opam install -y mirage"))
The following actions will be performed:
  - install conf-pkg-config   2      [required by opam-monorepo]
  - install ocamlfind         1.9.1  [required by astring, bos]
  - install seq               base   [required by lwt]
  - install cmdliner          1.0.4  [required by functoria]
  - install dune              2.9.1  [required by mirage]
  - install ocamlbuild        0.14.0 [required by astring, bos]
  - install base-bytes        base   [required by ocplib-endian]
  - install stdlib-shims      0.3.0  [required by ipaddr]
  - install result            1.5    [required by lwt]
  - install opam-monorepo     0.2.7  [required by mirage]
  - install mmap              1.1.0  [required by lwt]
  - install macaddr           5.2.0  [required by ipaddr]
  - install domain-name       0.4.0  [required by ipaddr]
  - install csexp             1.5.1  [required by dune-configurator]
  - install cppo              1.6.8  [required by lwt]
  - install topkg             1.0.4  [required by astring, bos]
  - install ocamlgraph        2.0.0  [required by functoria]
  - install ipaddr            5.2.0  [required by mirage]
  - install dune-configurator 2.9.1  [required by lwt]
  - install ocplib-endian     1.2    [required by lwt]
  - install rresult           0.7.0  [required by bos, functoria]
  - install fmt               0.9.0  [required by functoria, bos, mirage-runtime]
  - install astring           0.8.5  [required by mirage]
  - install lwt               5.5.0  [required by mirage-runtime]
  - install fpath             0.7.3  [required by bos, functoria]
  - install logs              0.7.0  [required by mirage]
  - install bos               0.2.1  [required by mirage]
  - install functoria-runtime 4.0.0  [required by mirage-runtime]
  - install functoria         4.0.0  [required by mirage]
  - install mirage-runtime    4.0.0  [required by mirage]
  - install mirage            4.0.0
===== 31 to install =====

The following system packages will first need to be installed:
    pkg-config

<><> Handling external dependencies <><><><><><><><><><><><><><><><><><><><><><>
Let opam run your package manager to install the required system packages?
(answer 'n' for other options) [Y/n] y
+ /usr/bin/sudo "apt-get" "install" "-qq" "-yy" "pkg-config"
- debconf: delaying package configuration, since apt-utils is not installed
- Selecting previously unselected package libglib2.0-0:amd64.
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 17391 files and directories currently installed.)
- Preparing to unpack .../0-libglib2.0-0_2.58.3-2+deb10u3_amd64.deb ...
- Unpacking libglib2.0-0:amd64 (2.58.3-2+deb10u3) ...
- Selecting previously unselected package libglib2.0-data.
- Preparing to unpack .../1-libglib2.0-data_2.58.3-2+deb10u3_all.deb ...
- Unpacking libglib2.0-data (2.58.3-2+deb10u3) ...
- Selecting previously unselected package libicu63:amd64.
- Preparing to unpack .../2-libicu63_63.1-6+deb10u2_amd64.deb ...
- Unpacking libicu63:amd64 (63.1-6+deb10u2) ...
- Selecting previously unselected package libxml2:amd64.
- Preparing to unpack .../3-libxml2_2.9.4+dfsg1-7+deb10u2_amd64.deb ...
- Unpacking libxml2:amd64 (2.9.4+dfsg1-7+deb10u2) ...
- Selecting previously unselected package pkg-config.
- Preparing to unpack .../4-pkg-config_0.29-6_amd64.deb ...
- Unpacking pkg-config (0.29-6) ...
- Selecting previously unselected package shared-mime-info.
- Preparing to unpack .../5-shared-mime-info_1.10-1_amd64.deb ...
- Unpacking shared-mime-info (1.10-1) ...
- Selecting previously unselected package xdg-user-dirs.
- Preparing to unpack .../6-xdg-user-dirs_0.17-2_amd64.deb ...
- Unpacking xdg-user-dirs (0.17-2) ...
- Setting up xdg-user-dirs (0.17-2) ...
- Setting up libglib2.0-0:amd64 (2.58.3-2+deb10u3) ...
- No schema files found: doing nothing.
- Setting up libicu63:amd64 (63.1-6+deb10u2) ...
- Setting up libglib2.0-data (2.58.3-2+deb10u3) ...
- Setting up pkg-config (0.29-6) ...
- Setting up libxml2:amd64 (2.9.4+dfsg1-7+deb10u2) ...
- Setting up shared-mime-info (1.10-1) ...
- Processing triggers for libc-bin (2.28-10) ...

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved bos.0.2.1  (cached)
-> retrieved astring.0.8.5  (cached)
-> retrieved cmdliner.1.0.4  (cached)
-> retrieved cppo.1.6.8  (cached)
-> retrieved csexp.1.5.1  (cached)
-> retrieved domain-name.0.4.0  (cached)
-> retrieved dune.2.9.1  (cached)
-> installed conf-pkg-config.2
-> retrieved dune-configurator.2.9.1  (cached)
-> retrieved fmt.0.9.0  (cached)
-> retrieved fpath.0.7.3  (cached)
-> retrieved ipaddr.5.2.0  (cached)
-> installed cmdliner.1.0.4
-> retrieved logs.0.7.0  (cached)
-> retrieved lwt.5.5.0  (cached)
-> retrieved macaddr.5.2.0  (cached)
-> retrieved functoria.4.0.0  (git+https://github.com/mirage/mirage.git#e1c01f21db31055e3290586faed6c110d7f136f2)
-> retrieved mirage.4.0.0  (git+https://github.com/mirage/mirage.git#e1c01f21db31055e3290586faed6c110d7f136f2)
-> retrieved mmap.1.1.0  (cached)
-> retrieved functoria-runtime.4.0.0  (git+https://github.com/mirage/mirage.git#e1c01f21db31055e3290586faed6c110d7f136f2)
-> retrieved ocamlbuild.0.14.0  (cached)
-> retrieved ocamlfind.1.9.1  (cached)
-> retrieved ocamlgraph.2.0.0  (cached)
-> retrieved ocplib-endian.1.2  (cached)
-> retrieved result.1.5  (cached)
-> retrieved rresult.0.7.0  (cached)
-> installed seq.base
-> retrieved stdlib-shims.0.3.0  (cached)
-> retrieved topkg.1.0.4  (cached)
-> retrieved mirage-runtime.4.0.0  (git+https://github.com/mirage/mirage.git#e1c01f21db31055e3290586faed6c110d7f136f2)
-> retrieved opam-monorepo.0.2.7  (cached)
-> installed ocamlfind.1.9.1
-> installed base-bytes.base
-> installed ocamlbuild.0.14.0
-> installed dune.2.9.1
-> installed csexp.1.5.1
-> installed domain-name.0.4.0
-> installed macaddr.5.2.0
-> installed mmap.1.1.0
-> installed stdlib-shims.0.3.0
-> installed result.1.5
-> installed topkg.1.0.4
-> installed cppo.1.6.8
-> installed ipaddr.5.2.0
-> installed ocplib-endian.1.2
-> installed rresult.0.7.0
-> installed dune-configurator.2.9.1
-> installed fmt.0.9.0
-> installed astring.0.8.5
-> installed ocamlgraph.2.0.0
-> installed fpath.0.7.3
-> installed lwt.5.5.0
-> installed logs.0.7.0
-> installed bos.0.2.1
-> installed functoria-runtime.4.0.0
-> installed mirage-runtime.4.0.0
-> installed functoria.4.0.0
-> installed opam-monorepo.0.2.7
-> installed mirage.4.0.0
Done.
# Run eval $(opam env) to update the current shell environment
2022-01-14 16:41.28 ---> saved as "cf4fe30f0847c4b36524868cb31190546253b8e406ce533957f1a9bb4c274365"

/home/opam: (copy (src .) (dst /src/))
2022-01-14 16:41.31 ---> saved as "e1cddc9c76de73149b2954db85604b13a2c2bcd79013a044880165a8162a3f03"

/home/opam: (env MODE hvt)

/home/opam: (workdir /src/)

/src/: (run (shell "opam exec -- make configure"))
mirage configure -f tutorial/noop/config.ml -t hvt 
mirage configure -f tutorial/noop-functor/config.ml -t hvt 
mirage configure -f tutorial/hello/config.ml -t hvt 
mirage configure -f tutorial/hello-key/config.ml -t hvt 
mirage configure -f tutorial/lwt/echo_server/config.ml -t hvt 
mirage configure -f tutorial/lwt/heads1/config.ml -t hvt 
mirage configure -f tutorial/lwt/heads2/config.ml -t hvt 
mirage configure -f tutorial/lwt/timeout1/config.ml -t hvt 
mirage configure -f tutorial/lwt/timeout2/config.ml -t hvt 
mirage configure -f tutorial/app_info/config.ml -t hvt 
mirage configure -f device-usage/clock/config.ml -t hvt 
mirage configure -f device-usage/conduit_server/config.ml -t hvt 
mirage configure -f device-usage/console/config.ml -t hvt 
mirage configure -f device-usage/http-fetch/config.ml -t hvt 
mirage configure -f device-usage/kv_ro/config.ml -t hvt 
mirage configure -f device-usage/network/config.ml -t hvt 
mirage configure -f device-usage/ping6/config.ml -t hvt 
mirage configure -f device-usage/prng/config.ml -t hvt 
mirage configure -f applications/dhcp/config.ml -t hvt 
mirage configure -f applications/git/config.ml -t hvt 
mirage configure -f applications/crypto/config.ml -t hvt 
mirage configure -f applications/static_website_tls/config.ml -t hvt 
mirage configure -f device-usage/block/config.ml -t hvt 
2022-01-14 16:41.58 ---> saved as "7ef3963406567d2bf2c99e51f9a9ca729afabf58c9ddb5694a41cd9df0e54325"

/src/: (env OVERLAY https://github.com/mirage/opam-overlays.git#3efd7da5947ed628eaa77e2253aa03bd1ac3867c)

/src/: (run (network host)
            (shell "opam exec -- make lock"))
[dune-universe] Initialised
[NOTE] Repository dune-universe has been added to the selections of switch 4.13 only.
       Run `opam repository add dune-universe --all-switches|--set-default' to use it in all existing switches, or in newly created switches, respectively.

opam monorepo lock --recurse-opam noop-hvt-monorepo noop_functor-hvt-monorepo hello-hvt-monorepo hello_key-hvt-monorepo echo_server-hvt-monorepo heads1-hvt-monorepo heads2-hvt-monorepo timeout1-hvt-monorepo timeout2-hvt-monorepo echo_server-hvt-monorepo app_info-hvt-monorepo speaking_clock-hvt-monorepo conduit_server-hvt-monorepo console-hvt-monorepo http_fetch-hvt-monorepo kv_ro-hvt-monorepo network-hvt-monorepo ping-hvt-monorepo prng-hvt-monorepo dhcp-hvt-monorepo minigit-hvt-monorepo crypto_test-hvt-monorepo https-hvt-monorepo block_test-hvt-monorepo --build-only --ocaml-version 4.13.1 -l ./mirage.opam.locked
==> Using 23 locally scanned packages as the targets.
opam-monorepo: [WARNING] Couldn't calculate a set of packages to satisfy the request. Note that opam monorepo lock will fail if not all of the project dependencies use dune as their build system, in your project that would be xenstore_transport,
                         xenstore, uchar, stringext, solo5-bindings-hvt, seq,
                         rresult, ptime, ppx_derivers, pbkdf, parse-argv,
                         ocplib-endian, ocamlfind, ocaml-freestanding,
                         ocaml-compiler-libs, num, mtime, mirage-profile,
                         mirage-bootvar-solo5, magic-mime, lru, logs, jsonm,
                         io-page, hkdf, fpath, duration, cohttp-mirage, bos,
                         bheap,
                         asn1-combinators. To solve this issue there exists a dune-universe opam-repository which contains dune ports for some opam packages, but it is currently not set in your current switch. If you wish to set it up, run the following command:
opam repository add dune-universe git+https://github.com/dune-universe/opam-overlays.git
opam-monorepo: Can't find all required versions.
               Selected: angstrom.0.15.0 app_info-hvt-monorepo.zdev asn1-combinators.0.2.6
                         astring.0.8.5+dune base-bigarray.base base-bytes.base
                         base-threads.base base-unix.base base64.3.5.0 bheap.2.0.0
                         bigarray-compat.1.0.0 bigstringaf.0.8.0
                         block_test-hvt-monorepo.zdev bos.0.2.0+dune ca-certs-nss.3.74
                         carton.0.4.3 carton-git.0.4.3 carton-lwt.0.4.3 checkseum.0.3.2
                         cmdliner.1.0.4+dune cohttp.5.0.0 cohttp-lwt.5.0.0
                         cohttp-mirage.5.0.0 conduit.5.0.0 conduit_server-hvt-monorepo.zdev
                         conf-gmp.3 conf-gmp-powm-sec.3 conf-m4.1 conf-pkg-config.2
                         console-hvt-monorepo.zdev cppo.1.6.8 crunch.3.2.0
                         crypto_test-hvt-monorepo.zdev csexp.1.5.1 cstruct.6.0.1
                         cstruct-sexp.6.0.1 decompress.1.4.2 digestif.1.1.0
                         domain-name.0.4.0 duff.0.4 dune.2.9.1 dune-build-info.2.9.1
                         dune-configurator.2.9.1 duration.0.2.0
                         echo_server-hvt-monorepo.zdev emile.1.1 encore.0.8 eqaf.0.8
                         findlib.1.8.1+dune fmt.0.8.9+dune fpath.0.7.3+dune
                         functoria-runtime.4.0.0 git.3.7.0 gmap.0.3.0 gmp.6.2.1-2
                         heads1-hvt-monorepo.zdev heads2-hvt-monorepo.zdev
                         hello-hvt-monorepo.zdev hello_key-hvt-monorepo.zdev hkdf.1.0.4
                         hxd.0.3.1 io-page.2.4.0 ipaddr.5.2.0 ipaddr-sexp.5.2.0
                         jsonm.1.0.1+dune ke.0.4 kv_ro-hvt-monorepo.zdev logs.0.7.0+dune
                         lru.0.3.0 lwt.5.5.0 macaddr.5.2.0 magic-mime.1.2.0 metrics.0.3.0
                         mimic.0.0.4 minigit-hvt-monorepo.zdev mirage-block.3.0.0
                         mirage-block-solo5.0.6.1 mirage-bootvar-solo5.0.6.0
                         mirage-channel.4.0.1 mirage-clock-unix.3.1.0 mirage-console.5.0.0
                         mirage-console-solo5.0.6.1 mirage-crypto.0.10.5
                         mirage-crypto-ec.0.10.5 mirage-crypto-pk.0.10.5
                         mirage-crypto-rng.0.10.5 mirage-crypto-rng-mirage.0.10.5
                         mirage-flow.3.0.0 mirage-flow-combinators.3.0.0 mirage-kv.4.0.0
                         mirage-kv-mem.3.0.0 mirage-logs.1.2.0 mirage-net.4.0.0
                         mirage-net-solo5.0.6.2 mirage-no-xen.1 mirage-profile.0.9.1
                         mirage-runtime.4.0.0 mirage-solo5.0.7.0+mirage mirage-stack.4.0.0
                         mirage-time.3.0.0 mmap.1.1.0 mtime.1.2.0+dune
                         network-hvt-monorepo.zdev noop-hvt-monorepo.zdev
                         noop_functor-hvt-monorepo.zdev num.1.3+dune
                         ocaml-base-compiler.4.13.1 ocaml-compiler-libs.v0.12.4
                         ocaml-config.2 ocaml-options-vanilla.1 ocaml-syntax-shims.1.0.0
                         ocamlfind.1.8.1+dune ocamlgraph.2.0.0 ocplib-endian.1.2
                         optint.0.1.0 parse-argv.0.2.0 parsexp.v0.14.2+mirage pbkdf.1.2.0
                         pecu.0.6 ppx_cstruct.6.0.1 ppx_derivers.1.2.1 ppx_sexp_conv.v0.14.3
                         ppxlib.0.24.0 prng-hvt-monorepo.zdev psq.0.2.0 ptime.0.8.5+dune
                         randomconv.0.1.3 re.1.10.3 result.1.5 rresult.0.6.0+dune
                         seq.base+dune sexplib.v0.14.0 sexplib0.v0.14.0
                         speaking_clock-hvt-monorepo.zdev stdlib-shims.0.3.0 stringext.1.6.0
                         timeout1-hvt-monorepo.zdev timeout2-hvt-monorepo.zdev tls.0.15.2
                         tls-mirage.0.15.2 uchar.0.0.2+dune uri.4.2.0 uri-sexp.4.2.0
                         uutf.1.0.2+dune vchan.6.0.0 x509.0.15.2 xenstore.2.1.1
                         xenstore_transport.1.3.0 zarith.1.11+mirage
                         ocaml-base-compiler&app_info-hvt-monorepo&block_test-hvt-monorepo&conduit_server-hvt-monorepo&console-hvt-monorepo&crypto_test-hvt-monorepo&dhcp-hvt-monorepo&echo_server-hvt-monorepo&heads1-hvt-monorepo&heads2-hvt-monorepo&hello-hvt-monorepo&hello_key-hvt-monorepo&http_fetch-hvt-monorepo&https-hvt-monorepo&kv_ro-hvt-monorepo&minigit-hvt-monorepo&network-hvt-monorepo&noop-hvt-monorepo&noop_functor-hvt-monorepo&ping-hvt-monorepo&prng-hvt-monorepo&speaking_clock-hvt-monorepo&timeout1-hvt-monorepo&timeout2-hvt-monorepo
                         ocaml-base-compiler ocaml-base-compiler ocaml ocaml
                         ocaml-base-compiler solo5-bindings-hvt ocaml-freestanding gmp
                         mirage-no-solo5&mirage-no-xen
               - arp -> arp.2.3.2
                   conduit_server-hvt-monorepo zdev requires >= 2.3.0 & < 3.0.0
               - base -> base.v0.14.2
                   parsexp v0.14.2+mirage requires >= v0.14 & < v0.15
               - conduit-lwt -> (problem)
                   conduit-mirage 4.0.2 requires = 4.0.2
                   Rejected candidates:
                     conduit-lwt.1.1.0: Doesn't build with dune
                     conduit-lwt.1.0.3: Doesn't build with dune
                     conduit-lwt.1.0.0: Doesn't build with dune
                     conduit-lwt.5.0.0: Incompatible with restriction: = 4.0.2
                     conduit-lwt.4.0.2: Requires conduit = 4.0.2
                     ...
               - conduit-mirage -> conduit-mirage.4.0.2
                   conduit_server-hvt-monorepo zdev requires >= 4.0.0 & < 5.0.0
               - dhcp-hvt-monorepo -> (problem)
                   Rejected candidates:
                     dhcp-hvt-monorepo.zdev: Requires arp >= 3.0.0
               - dns -> dns.5.0.1
                   dns-client 5.0.1 requires = 5.0.1
               - dns-client -> dns-client.5.0.1
                   conduit-mirage 4.0.2 requires >= 5.0.0 & < 6.0.0
               - ethernet -> ethernet.2.2.1
                   conduit_server-hvt-monorepo zdev requires >= 2.2.0 & < 3.0.0
               - git-mirage -> (problem)
                   Rejected candidates:
                     git-mirage.1.11.4: Doesn't build with dune
                     git-mirage.1.11.2: Doesn't build with dune
                     git-mirage.1.11.0: Doesn't build with dune
                     git-mirage.1.10.0: Doesn't build with dune
                     git-mirage.3.7.0: Requires dns >= 6.1.3
                     ...
               - http_fetch-hvt-monorepo -> (problem)
                   Rejected candidates:
                     http_fetch-hvt-monorepo.zdev: Requires cohttp-mirage >= 4.0.0 & < 5.0.0
               - https-hvt-monorepo -> (problem)
                   Rejected candidates:
                     https-hvt-monorepo.zdev: Requires cohttp-mirage >= 4.0.0 & < 5.0.0
               - mirage-clock -> mirage-clock.3.1.0
                   mirage-clock-freestanding 3.1.0 requires = 3.1.0
               - mirage-clock-freestanding -> mirage-clock-freestanding.3.1.0
                   app_info-hvt-monorepo zdev requires >= 3.1.0 & < 4.0.0
               - mirage-no-solo5 -> (problem)
                   Rejected candidates:
                     mirage-no-solo5.1: Requires mirage-solo5 conflict with all versions
               - mirage-protocols -> mirage-protocols.7.0.0
                   arp 2.3.2 requires >= 4.0.0 & < 8.0.0
               - mirage-random -> mirage-random.2.0.0
                   conduit_server-hvt-monorepo zdev requires >= 2.0.0 & < 3.0.0
               - ocaml -> ocaml.4.13.1
                   User requested = 4.13.1
               - ocaml-freestanding -> (problem)
                   No usable implementations:
                     ocaml-freestanding.0.7.0: Doesn't build with dune
                     ocaml-freestanding.0.6.6: Doesn't build with dune
                     ocaml-freestanding.0.6.5: Doesn't build with dune
                     ocaml-freestanding.0.6.4: Doesn't build with dune
                     ocaml-freestanding.0.6.3: Doesn't build with dune
                     ...
               - ping-hvt-monorepo -> (problem)
                   Rejected candidates:
                     ping-hvt-monorepo.zdev: Requires ethernet >= 2.2.0 & >= 3.0.0 & < 3.0.0
               - solo5-bindings-hvt -> (problem)
                   No usable implementations:
                     solo5-bindings-hvt.0.6.9: Doesn't build with dune
                     solo5-bindings-hvt.0.6.8: Doesn't build with dune
                     solo5-bindings-hvt.0.6.7: Doesn't build with dune
                     solo5-bindings-hvt.0.6.6: Doesn't build with dune
                     solo5-bindings-hvt.0.6.5: Doesn't build with dune
                     ...
               - tcpip -> (problem)
                   conduit_server-hvt-monorepo zdev requires >= 6.1.0 & < 7.0.0
                   mirage-stack 4.0.0 requires >= 7.0.0
                   Rejected candidates:
                     tcpip.3.6.0: Doesn't build with dune
                     tcpip.3.5.1: Doesn't build with dune
                     tcpip.3.5.0: Doesn't build with dune
                     tcpip.3.4.2: Doesn't build with dune
                     tcpip.3.4.1: Doesn't build with dune
                     ...
make: *** [Makefile:65: lock] Error 1
"/bin/bash" "-c" "opam exec -- make lock" failed with exit status 2

2022-01-14 16:42.55: Job failed: Failed: Build failed