Build:
  1. 0
2022-05-04 08:55.43: New job: Build using linux-x86_64 in
                                [https://github.com/mirage/mirage-skeleton.git#refs/heads/main (6081b31e2ca250c05cdcb643c092190f63c768c0)]

OBuilder spec:

((from ocaml/opam:debian-10-ocaml-4.13)
 (user (uid 1000) (gid 1000))
 (workdir /home/opam)
 (run (shell "sudo chown opam:opam /home/opam"))
 (run (shell "sudo ln -f /usr/bin/opam-2.1 /usr/bin/opam && opam update"))
 (run (network host)
      (shell "opam repo add opam https://github.com/ocaml/opam-repository.git#f89a89bc06734a0f70b04fb3dedc0507eb7ab910"))
 (run (network host)
      (shell "opam repo add mirage-dev https://github.com/mirage/mirage-dev.git#842c55556ffd0950d21141d6ab99e52a8d88a50f"))
 (run (cache (download-cache (target /home/opam/.opam/download-cache)))
      (network host)
      (shell "sudo apt-get update && opam install -y \"mirage>=4\""))
 (copy (src .) (dst /src/))
 (env MODE hvt)
 (workdir /src/)
 (run (shell "opam exec -- make configure"))
 (env MIRAGE_EXTRA_REPOS opam-overlays:https://github.com/dune-universe/opam-overlays.git#7c6a2ce7ebaf5c5119a23ea297d2f189b4bb3efd,mirage-opam-overlays:https://github.com/dune-universe/mirage-opam-overlays.git#a59e36702822c31e662b242c6d056a31533590e6)
 (run (network host)
      (shell "opam exec -- make lock"))
 (run (cache (download-cache (target /home/opam/.opam/download-cache)))
      (network host)
      (shell "sudo apt-get update && opam exec -- make depends"))
 (run (shell "opam monorepo list -l mirage.opam.locked"))
 (run (cache (download-cache (target /home/opam/.opam/download-cache)))
      (network host)
      (shell "opam exec -- make pull"))
 (env DUNE_CACHE enabled)
 (env DUNE_CACHE_TRANSPORT direct)
 (run (cache (dune-build-cache (target /home/opam/.cache/dune)))
      (network host)
      (shell "opam exec -- make build"))
)

2022-05-04 08:55.43: Using cache hint "mirage-ci-skeleton-debian-10-ocaml-4.13"
2022-05-04 08:55.43: Waiting for resource in pool OCluster
2022-05-04 08:55.43: Waiting for worker...
2022-05-04 08:55.43: Got resource from pool OCluster
Building on pima.ocamllabs.io
All commits already cached
HEAD is now at 6081b31 Merge pull request #340 from TheLortex/single-opam-file

(from ocaml/opam:debian-10-ocaml-4.13)
2022-05-04 08:56.33 ---> saved as "cbba9511e46ef57631453d5b88aeed1ed6de6fa87b6f0dcb3da9328657d73fa4"

/: (user (uid 1000) (gid 1000))

/: (workdir /home/opam)

/home/opam: (run (shell "sudo chown opam:opam /home/opam"))
2022-05-04 08:56.35 ---> saved as "0afede13af6ea6d75cbfcfb80353059bc4fd4eea40a723ef627f0c4946f2e079"

/home/opam: (run (shell "sudo ln -f /usr/bin/opam-2.1 /usr/bin/opam && opam update"))
Continue? [Y/n] y
This development version of opam requires an update to the layout of /home/opam/.opam from version 2.0 to version 2.1, which can't be reverted.
You may want to back it up before going further.

Format upgrade done.

<><> Updating package repositories ><><><><><><><><><><><><><><><><><><><><><><>
[default] synchronised from file:///home/opam/opam-repository
2022-05-04 08:59.59 ---> saved as "88933084999984163bc104ca2978b0ba2b9c83ff33e4e30c3b6dae7cb5cde9bc"

/home/opam: (run (network host)
                 (shell "opam repo add opam https://github.com/ocaml/opam-repository.git#f89a89bc06734a0f70b04fb3dedc0507eb7ab910"))
[opam] Initialised
[NOTE] Repository opam has been added to the selections of switch 4.13 only.
       Run `opam repository add opam --all-switches|--set-default' to use it in all existing switches, or in newly created switches, respectively.

2022-05-04 09:02.55 ---> saved as "3a73d579888608643c721e27de661e79db6b6974c55de2da29a23a6d17552a14"

/home/opam: (run (network host)
                 (shell "opam repo add mirage-dev https://github.com/mirage/mirage-dev.git#842c55556ffd0950d21141d6ab99e52a8d88a50f"))
[mirage-dev] Initialised
[NOTE] Repository mirage-dev has been added to the selections of switch 4.13 only.
       Run `opam repository add mirage-dev --all-switches|--set-default' to use it in all existing switches, or in newly created switches, respectively.

2022-05-04 09:03.14 ---> saved as "fe491416763c980c0b4ac5f6aeadc6532ca29186298f7d8170e8a685d0882b8b"

/home/opam: (run (cache (download-cache (target /home/opam/.opam/download-cache)))
                 (network host)
                 (shell "sudo apt-get update && opam install -y \"mirage>=4\""))
Get:1 http://security.debian.org/debian-security buster/updates InRelease [65.4 kB]
Get:2 http://deb.debian.org/debian buster InRelease [122 kB]
Get:3 http://deb.debian.org/debian buster-updates InRelease [51.9 kB]
Get:4 http://security.debian.org/debian-security buster/updates/main amd64 Packages [318 kB]
Get:5 http://deb.debian.org/debian buster/main amd64 Packages [7911 kB]
Get:6 http://deb.debian.org/debian buster-updates/main amd64 Packages.diff/Index [10.6 kB]
Get:7 http://deb.debian.org/debian buster-updates/main amd64 Packages 2022-03-26-2012.00.pdiff [168 B]
Get:7 http://deb.debian.org/debian buster-updates/main amd64 Packages 2022-03-26-2012.00.pdiff [168 B]
Fetched 8479 kB in 2s (3429 kB/s)
Reading package lists...
The following actions will be performed:
  - install seq                base   [required by lwt]
  - install ocamlbuild         0.14.1 [required by astring, bos]
  - install cmdliner           1.1.1  [required by functoria]
  - install conf-pkg-config    2      [required by opam-monorepo]
  - install dune               3.1.1  [required by mirage]
  - install ocamlfind          1.9.3  [required by astring, bos]
  - install stdlib-shims       0.3.0  [required by ipaddr]
  - install result             1.5    [required by functoria]
  - install pecu               0.6    [required by emile]
  - install opam-monorepo      0.2.7  [required by mirage]
  - install ocaml-syntax-shims 1.0.0  [required by lwt, angstrom]
  - install macaddr            5.3.0  [required by ipaddr]
  - install domain-name        0.4.0  [required by ipaddr]
  - install csexp              1.5.1  [required by dune-configurator]
  - install cppo               1.6.8  [required by lwt]
  - install bigstringaf        0.9.0  [required by emile]
  - install bigarray-compat    1.1.0  [required by mmap]
  - install base64             3.5.0  [required by emile]
  - install topkg              1.0.5  [required by astring, bos]
  - install base-bytes         base   [required by stringext]
  - install ipaddr             5.3.0  [required by mirage]
  - install dune-configurator  3.1.1  [required by lwt]
  - install angstrom           0.15.0 [required by emile, uri]
  - install mmap               1.2.0  [required by lwt]
  - install uutf               1.0.3  [required by emile]
  - install rresult            0.7.0  [required by bos, functoria]
  - install fmt                0.9.0  [required by functoria, bos, mirage-runtime]
  - install astring            0.8.5  [required by mirage]
  - install stringext          1.6.0  [required by uri]
  - install ocplib-endian      1.2    [required by lwt]
  - install emile              1.1    [required by functoria]
  - install functoria-runtime  4.0.0  [required by mirage-runtime]
  - install fpath              0.7.3  [required by bos, functoria]
  - install uri                4.2.0  [required by functoria]
  - install lwt                5.5.0  [required by mirage-runtime]
  - install logs               0.7.0  [required by mirage]
  - install mirage-runtime     4.0.0  [required by mirage]
  - install bos                0.2.1  [required by mirage]
  - install functoria          4.0.0  [required by mirage]
  - install mirage             4.0.0
===== 40 to install =====

The following system packages will first need to be installed:
    pkg-config

<><> Handling external dependencies <><><><><><><><><><><><><><><><><><><><><><>
Let opam run your package manager to install the required system packages?
(answer 'n' for other options) [Y/n] y
+ /usr/bin/sudo "apt-get" "install" "-qq" "-yy" "pkg-config"
- debconf: delaying package configuration, since apt-utils is not installed
- Selecting previously unselected package libglib2.0-0:amd64.
- (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 17391 files and directories currently installed.)
- Preparing to unpack .../0-libglib2.0-0_2.58.3-2+deb10u3_amd64.deb ...
- Unpacking libglib2.0-0:amd64 (2.58.3-2+deb10u3) ...
- Selecting previously unselected package libglib2.0-data.
- Preparing to unpack .../1-libglib2.0-data_2.58.3-2+deb10u3_all.deb ...
- Unpacking libglib2.0-data (2.58.3-2+deb10u3) ...
- Selecting previously unselected package libicu63:amd64.
- Preparing to unpack .../2-libicu63_63.1-6+deb10u3_amd64.deb ...
- Unpacking libicu63:amd64 (63.1-6+deb10u3) ...
- Selecting previously unselected package libxml2:amd64.
- Preparing to unpack .../3-libxml2_2.9.4+dfsg1-7+deb10u3_amd64.deb ...
- Unpacking libxml2:amd64 (2.9.4+dfsg1-7+deb10u3) ...
- Selecting previously unselected package pkg-config.
- Preparing to unpack .../4-pkg-config_0.29-6_amd64.deb ...
- Unpacking pkg-config (0.29-6) ...
- Selecting previously unselected package shared-mime-info.
- Preparing to unpack .../5-shared-mime-info_1.10-1_amd64.deb ...
- Unpacking shared-mime-info (1.10-1) ...
- Selecting previously unselected package xdg-user-dirs.
- Preparing to unpack .../6-xdg-user-dirs_0.17-2_amd64.deb ...
- Unpacking xdg-user-dirs (0.17-2) ...
- Setting up xdg-user-dirs (0.17-2) ...
- Setting up libglib2.0-0:amd64 (2.58.3-2+deb10u3) ...
- No schema files found: doing nothing.
- Setting up libicu63:amd64 (63.1-6+deb10u3) ...
- Setting up libglib2.0-data (2.58.3-2+deb10u3) ...
- Setting up pkg-config (0.29-6) ...
- Setting up libxml2:amd64 (2.9.4+dfsg1-7+deb10u3) ...
- Setting up shared-mime-info (1.10-1) ...
- Processing triggers for libc-bin (2.28-10) ...

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
-> retrieved base64.3.5.0  (cached)
-> retrieved angstrom.0.15.0  (cached)
-> retrieved astring.0.8.5  (cached)
-> retrieved bigarray-compat.1.1.0  (cached)
-> retrieved bigstringaf.0.9.0  (cached)
-> retrieved bos.0.2.1  (cached)
-> retrieved cmdliner.1.1.1  (cached)
-> retrieved cppo.1.6.8  (cached)
-> retrieved csexp.1.5.1  (cached)
-> retrieved domain-name.0.4.0  (cached)
-> retrieved dune.3.1.1  (cached)
-> installed conf-pkg-config.2
-> retrieved dune-configurator.3.1.1  (cached)
-> retrieved emile.1.1  (cached)
-> retrieved fmt.0.9.0  (cached)
-> retrieved fpath.0.7.3  (cached)
-> retrieved functoria.4.0.0  (cached)
-> retrieved functoria-runtime.4.0.0  (cached)
-> retrieved ipaddr.5.3.0  (cached)
-> installed cmdliner.1.1.1
-> retrieved logs.0.7.0  (cached)
-> retrieved lwt.5.5.0  (cached)
-> retrieved macaddr.5.3.0  (cached)
-> retrieved mirage.4.0.0  (cached)
-> retrieved mirage-runtime.4.0.0  (cached)
-> retrieved mmap.1.2.0  (cached)
-> retrieved ocaml-syntax-shims.1.0.0  (cached)
-> retrieved ocamlbuild.0.14.1  (cached)
-> retrieved ocamlfind.1.9.3  (cached)
-> retrieved ocplib-endian.1.2  (cached)
-> retrieved pecu.0.6  (cached)
-> retrieved result.1.5  (cached)
-> installed seq.base
-> retrieved rresult.0.7.0  (cached)
-> retrieved stdlib-shims.0.3.0  (cached)
-> retrieved stringext.1.6.0  (cached)
-> retrieved topkg.1.0.5  (cached)
-> retrieved uri.4.2.0  (cached)
-> retrieved uutf.1.0.3  (cached)
-> retrieved opam-monorepo.0.2.7  (cached)
-> installed ocamlfind.1.9.3
-> installed base-bytes.base
-> installed ocamlbuild.0.14.1
-> installed topkg.1.0.5
-> installed rresult.0.7.0
-> installed uutf.1.0.3
-> installed fmt.0.9.0
-> installed astring.0.8.5
-> installed fpath.0.7.3
-> installed dune.3.1.1
-> installed base64.3.5.0
-> installed bigarray-compat.1.1.0
-> installed bigstringaf.0.9.0
-> installed csexp.1.5.1
-> installed cppo.1.6.8
-> installed domain-name.0.4.0
-> installed functoria-runtime.4.0.0
-> installed macaddr.5.3.0
-> installed ocaml-syntax-shims.1.0.0
-> installed pecu.0.6
-> installed result.1.5
-> installed stdlib-shims.0.3.0
-> installed stringext.1.6.0
-> installed mmap.1.2.0
-> installed ocplib-endian.1.2
-> installed angstrom.0.15.0
-> installed ipaddr.5.3.0
-> installed emile.1.1
-> installed dune-configurator.3.1.1
-> installed uri.4.2.0
-> installed lwt.5.5.0
-> installed logs.0.7.0
-> installed mirage-runtime.4.0.0
-> installed bos.0.2.1
-> installed functoria.4.0.0
-> installed opam-monorepo.0.2.7
-> installed mirage.4.0.0
Done.
# Run eval $(opam env) to update the current shell environment
2022-05-04 09:05.49 ---> saved as "6c88215b39cee7905b89add323553702a84f862d539a4eba0a3f184e45b88be9"

/home/opam: (copy (src .) (dst /src/))
2022-05-04 09:06.12 ---> saved as "5fc32b8da6a66d4c6f986855eb7b795339edd59e4046f94d6be30c328cdb41c9"

/home/opam: (env MODE hvt)

/home/opam: (workdir /src/)

/src/: (run (shell "opam exec -- make configure"))
mirage configure -f tutorial/noop/config.ml -t hvt 
mirage configure -f tutorial/noop-functor/config.ml -t hvt 
mirage configure -f tutorial/hello/config.ml -t hvt 
mirage configure -f tutorial/hello-key/config.ml -t hvt 
mirage configure -f tutorial/lwt/echo_server/config.ml -t hvt 
mirage configure -f tutorial/lwt/heads1/config.ml -t hvt 
mirage configure -f tutorial/lwt/heads2/config.ml -t hvt 
mirage configure -f tutorial/lwt/timeout1/config.ml -t hvt 
mirage configure -f tutorial/lwt/timeout2/config.ml -t hvt 
mirage configure -f tutorial/app_info/config.ml -t hvt 
mirage configure -f device-usage/clock/config.ml -t hvt 
mirage configure -f device-usage/conduit_server/config.ml -t hvt 
mirage configure -f device-usage/console/config.ml -t hvt 
mirage configure -f device-usage/http-fetch/config.ml -t hvt 
mirage configure -f device-usage/kv_ro/config.ml -t hvt 
mirage configure -f device-usage/network/config.ml -t hvt 
mirage configure -f device-usage/ping6/config.ml -t hvt 
mirage configure -f device-usage/prng/config.ml -t hvt 
mirage configure -f applications/docteur/config.ml -t hvt 
mirage configure -f applications/dhcp/config.ml -t hvt 
mirage configure -f applications/git/config.ml -t hvt 
mirage configure -f applications/dns/config.ml -t hvt 
mirage configure -f applications/crypto/config.ml -t hvt 
mirage configure -f applications/static_website_tls/config.ml -t hvt 
mirage configure -f device-usage/block/config.ml -t hvt 
2022-05-04 09:07.05 ---> saved as "42995f6e5a8b65e9c034f501818a920a1229621b81b73b73de4af5b23b9c491f"

/src/: (env MIRAGE_EXTRA_REPOS opam-overlays:https://github.com/dune-universe/opam-overlays.git#7c6a2ce7ebaf5c5119a23ea297d2f189b4bb3efd,mirage-opam-overlays:https://github.com/dune-universe/mirage-opam-overlays.git#a59e36702822c31e662b242c6d056a31533590e6)

/src/: (run (network host)
            (shell "opam exec -- make lock"))
[opam-overlays] Initialised
[NOTE] Repository opam-overlays has been added to the selections of switch 4.13 only.
       Run `opam repository add opam-overlays --all-switches|--set-default' to use it in all existing switches, or in newly created switches, respectively.

[mirage-opam-overlays] Initialised
[NOTE] Repository mirage-opam-overlays has been added to the selections of switch 4.13 only.
       Run `opam repository add mirage-opam-overlays --all-switches|--set-default' to use it in all existing switches, or in newly created switches, respectively.

opam monorepo lock --recurse-opam noop-hvt-monorepo noop-hvt-switch noop-functor-hvt-monorepo noop-functor-hvt-switch hello-hvt-monorepo hello-hvt-switch hello-key-hvt-monorepo hello-key-hvt-switch echo_server-hvt-monorepo echo_server-hvt-switch heads1-hvt-monorepo heads1-hvt-switch heads2-hvt-monorepo heads2-hvt-switch timeout1-hvt-monorepo timeout1-hvt-switch timeout2-hvt-monorepo timeout2-hvt-switch echo_server-hvt-monorepo echo_server-hvt-switch app-info-hvt-monorepo app-info-hvt-switch speaking_clock-hvt-monorepo speaking_clock-hvt-switch conduit_server-hvt-monorepo conduit_server-hvt-switch console-hvt-monorepo console-hvt-switch http-fetch-hvt-monorepo http-fetch-hvt-switch kv_ro-hvt-monorepo kv_ro-hvt-switch network-hvt-monorepo network-hvt-switch ping-hvt-monorepo ping-hvt-switch prng-hvt-monorepo prng-hvt-switch static_kv_ro-hvt-monorepo static_kv_ro-hvt-switch dhcp-hvt-monorepo dhcp-hvt-switch minigit-hvt-monorepo minigit-hvt-switch resolve-hvt-monorepo resolve-hvt-switch crypto-test-hvt-monorepo crypto-test-hvt-switch https-hvt-monorepo https-hvt-switch block_test-hvt-monorepo block_test-hvt-switch --build-only --ocaml-version 4.13.1 -l ./mirage.opam.locked
==> Using 50 locally scanned packages as the targets.
opam-monorepo: Can't find all required versions.
               Selected: angstrom.0.15.0 app-info-hvt-monorepo.zdev app-info-hvt-switch.zdev
                         arp.3.0.0 art.0.1.1 asn1-combinators.0.2.6 astring.0.8.5+dune
                         awa.0.1.0 awa-mirage.0.1.0 base.v0.15.0 base-bigarray.base
                         base-bytes.base base-threads.base base-unix.base base64.3.5.0
                         bheap.2.0.0 bigarray-compat.1.1.0 bigstringaf.0.9.0
                         block_test-hvt-monorepo.zdev block_test-hvt-switch.zdev
                         bos.0.2.1+dune ca-certs.0.2.2 ca-certs-nss.3.77 carton.0.4.4
                         carton-git.0.4.4 carton-lwt.0.4.4 charrua.1.5.0
                         charrua-server.1.5.0 checkseum.0.3.3 cmdliner.1.1.1+dune
                         cohttp.5.0.0 cohttp-lwt.5.0.0 cohttp-mirage.5.0.0 conduit.5.1.0
                         conduit-lwt.5.1.0 conduit-mirage.5.1.0
                         conduit_server-hvt-monorepo.zdev conduit_server-hvt-switch.zdev
                         conf-gmp.4 conf-gmp-powm-sec.3 conf-m4.1 conf-pkg-config.2
                         console-hvt-monorepo.zdev console-hvt-switch.zdev cppo.1.6.8
                         crunch.3.2.0 crypto-test-hvt-monorepo.zdev
                         crypto-test-hvt-switch.zdev csexp.1.5.1 cstruct.6.1.0
                         cstruct-lwt.6.1.0 cstruct-sexp.6.1.0 cstruct-unix.6.1.0
                         decompress.1.4.3 dhcp-hvt-monorepo.zdev dhcp-hvt-switch.zdev
                         digestif.1.1.2 dns.6.2.2 dns-client.6.2.2 docteur.0.0.5
                         docteur-solo5.0.0.5 domain-name.0.4.0 duff.0.5 dune.3.1.1
                         dune-build-info.3.1.1 dune-configurator.3.1.1 duration.0.2.0
                         echo_server-hvt-monorepo.zdev echo_server-hvt-switch.zdev emile.1.1
                         encore.0.8 eqaf.0.8 ethernet.3.0.0 faraday.0.8.1 findlib.1.8.1+dune
                         fmt.0.9.0+dune fpath.0.7.3+dune functoria.4.0.0
                         functoria-runtime.4.0.0 git.3.9.1 git-mirage.3.9.1 git-paf.3.9.1
                         git-unix.3.9.1 gmap.0.3.0 gmp.6.2.1-2 h2.0.8.0 happy-eyeballs.0.3.0
                         happy-eyeballs-lwt.0.3.0 happy-eyeballs-mirage.0.3.0
                         heads1-hvt-monorepo.zdev heads1-hvt-switch.zdev
                         heads2-hvt-monorepo.zdev heads2-hvt-switch.zdev
                         hello-hvt-monorepo.zdev hello-hvt-switch.zdev
                         hello-key-hvt-monorepo.zdev hello-key-hvt-switch.zdev hex.1.5.0
                         hkdf.1.0.4 hpack.0.2.0 http-fetch-hvt-monorepo.zdev
                         http-fetch-hvt-switch.zdev httpaf.0.7.1 https-hvt-monorepo.zdev
                         https-hvt-switch.zdev hxd.0.3.2 io-page.3.0.0 ipaddr.5.3.0
                         ipaddr-sexp.5.3.0 jsonm.1.0.1+dune ke.0.6 kv_ro-hvt-monorepo.zdev
                         kv_ro-hvt-switch.zdev logs.0.7.0+dune2 lru.0.3.0 lwt.5.5.0
                         lwt-dllist.1.0.1 macaddr.5.3.0 macaddr-cstruct.5.3.0
                         macaddr-sexp.5.3.0 magic-mime.1.2.0 menhir.20220210
                         menhirLib.20220210 menhirSdk.20220210 metrics.0.4.0 mimic.0.0.5
                         mimic-happy-eyeballs.0.0.5 minigit-hvt-monorepo.zdev
                         minigit-hvt-switch.zdev mirage.4.0.0 mirage-block.3.0.0
                         mirage-block-solo5.0.8.0 mirage-bootvar-solo5.0.6.0
                         mirage-channel.4.1.0 mirage-clock.4.2.0 mirage-clock-solo5.4.2.0
                         mirage-clock-unix.4.2.0 mirage-console.5.1.0
                         mirage-console-solo5.0.8.0 mirage-crypto.0.10.6
                         mirage-crypto-ec.0.10.6 mirage-crypto-pk.0.10.6
                         mirage-crypto-rng.0.10.6 mirage-crypto-rng-mirage.0.10.6
                         mirage-flow.3.0.0 mirage-flow-combinators.3.0.0 mirage-kv.4.0.1
                         mirage-kv-mem.3.0.0 mirage-logs.1.2.0 mirage-net.4.0.0
                         mirage-net-solo5.0.8.0 mirage-no-xen.1 mirage-profile.0.9.1
                         mirage-random.3.0.0 mirage-runtime.4.0.0 mirage-solo5.0.8.0
                         mirage-time.3.0.0 mirage-unix.5.0.0 mmap.1.2.0 mtime.1.4.0+dune
                         network-hvt-monorepo.zdev network-hvt-switch.zdev
                         noop-functor-hvt-monorepo.zdev noop-functor-hvt-switch.zdev
                         noop-hvt-monorepo.zdev noop-hvt-switch.zdev num.1.4+dune
                         ocaml-base-compiler.4.13.1 ocaml-compiler-libs.v0.12.4
                         ocaml-config.2 ocaml-options-vanilla.1 ocaml-syntax-shims.1.0.0
                         ocamlfind.1.8.1+dune ocamlgraph.2.0.0 ocplib-endian.1.2
                         optint.0.2.0 paf.0.0.9 parse-argv.0.2.0 parsexp.v0.15.0 pbkdf.1.2.0
                         pecu.0.6 ping-hvt-monorepo.zdev ping-hvt-switch.zdev
                         ppx_cstruct.6.1.0 ppx_derivers.1.2.1 ppx_sexp_conv.v0.15.1
                         ppxlib.0.26.0 prng-hvt-monorepo.zdev prng-hvt-switch.zdev psq.0.2.0
                         ptime.1.0.0+dune2 randomconv.0.1.3 re.1.10.4
                         resolve-hvt-monorepo.zdev resolve-hvt-switch.zdev result.1.5
                         rresult.0.7.0+dune seq.base+dune sexplib.v0.15.0 sexplib0.v0.15.0
                         speaking_clock-hvt-monorepo.zdev speaking_clock-hvt-switch.zdev
                         static_kv_ro-hvt-monorepo.zdev static_kv_ro-hvt-switch.zdev
                         stdlib-shims.0.3.0 stringext.1.6.0 tcpip.7.1.0
                         timeout1-hvt-monorepo.zdev timeout1-hvt-switch.zdev
                         timeout2-hvt-monorepo.zdev timeout2-hvt-switch.zdev tls.0.15.3
                         tls-mirage.0.15.3 uri.4.2.0 uri-sexp.4.2.0 uutf.1.0.3+dune
                         vchan.6.0.1 x509.0.16.0 xenstore.2.1.1 xenstore_transport.1.3.0
                         zarith.1.12+dune+mirage
                         ocaml-base-compiler&app-info-hvt-monorepo&app-info-hvt-switch&block_test-hvt-monorepo&block_test-hvt-switch&conduit_server-hvt-monorepo&conduit_server-hvt-switch&console-hvt-monorepo&console-hvt-switch&crypto-test-hvt-monorepo&crypto-test-hvt-switch&dhcp-hvt-monorepo&dhcp-hvt-switch&echo_server-hvt-monorepo&echo_server-hvt-switch&heads1-hvt-monorepo&heads1-hvt-switch&heads2-hvt-monorepo&heads2-hvt-switch&hello-hvt-monorepo&hello-hvt-switch&hello-key-hvt-monorepo&hello-key-hvt-switch&http-fetch-hvt-monorepo&http-fetch-hvt-switch&https-hvt-monorepo&https-hvt-switch&kv_ro-hvt-monorepo&kv_ro-hvt-switch&minigit-hvt-monorepo&minigit-hvt-switch&network-hvt-monorepo&network-hvt-switch&noop-functor-hvt-monorepo&noop-functor-hvt-switch&noop-hvt-monorepo&noop-hvt-switch&ping-hvt-monorepo&ping-hvt-switch&prng-hvt-monorepo&prng-hvt-switch&resolve-hvt-monorepo&resolve-hvt-switch&speaking_clock-hvt-monorepo&speaking_clock-hvt-switch&static_kv_ro-hvt-monorepo&static_kv_ro-hvt-switch&timeout1-hvt-monorepo&timeout1-hvt-switch&timeout2-hvt-monorepo&timeout2-hvt-switch
                         ocaml-base-compiler ocaml-base-compiler ocaml ocaml
                         ocaml-base-compiler gmp mirage-no-solo5&mirage-no-xen
               - mirage-no-solo5 -> (problem)
                   Rejected candidates:
                     mirage-no-solo5.1: Requires mirage-solo5 conflict with all versions
               - ocaml -> ocaml.4.13.1
                   User requested = 4.13.1
               - ocaml-solo5 -> (problem)
                   No usable implementations:
                     ocaml-solo5.0.8.0: Doesn't build with dune
               - opam-monorepo -> opam-monorepo.0.2.7
                   mirage 4.0.0 requires >= 0.2.6 & < 0.3.0
make: *** [Makefile:67: lock] Error 1
"/bin/bash" "-c" "opam exec -- make lock" failed with exit status 2

2022-05-04 09:08.15: Job failed: Failed: Build failed